DIY Laundry Assistant

Annette Ibarra, Sierra Scott, Sara Wille

Capstone: A Makerspace Experience

Spring 2018
Introduction

Welcome to the University of Puget Sound Makerspace! In this tutorial, you are going to learn how to make a sensor for a washer or dryer that will text you when your laundry load is done*. You will learn to use several technologies in the Makerspace including an Arduino, a 3D printer, and optionally, a soldering iron.

Makerspace Technologies

**Arduinos** are basically tiny computers that can do very simple tasks. In this project, we will use an Arduino to read inputs from an accelerometer, a little device used to detect vibration, and determine when the washer or dryer is no longer running (when the vibrations stop). By the end of this tutorial, you should have a basic understanding of how Arduinos work and how to use them.
3D Printers make three dimensional objects from digital files. We will be using two 3D printers, MakerBot Replicator+ (pictured to the left) and Markforged Onyx One (pictured below) to print a case for the laundry sensor one it has been assembled. This tutorial should teach you the basics of how to use each 3D printer. Remember that the Makerspace staff can also give you additional help as needed!

Soldering Irons are used to attach metals to each other, and are often used for connecting electronic components. In this tutorial, we will cover two types of accelerometers, and only one requires soldering. We will be attaching the accelerometer to small pins which will allow it to be connected to the rest of the system. (pictured below)
Step 1

Materials
What will you need?

First, you need to collect the materials for this project*. You will need:

**Arduino Yun**
A type of Arduino which has built-in wifi. *(pictured to the right)*

**Accelerometer**
An instrument for measuring acceleration or vibration. In this tutorial, we will cover two types: the *Memsic 2125*, which *does not* require soldering and the *ADXL-335*, which *does* require soldering.
Solderless Breadboard
This makes wiring things together much easier because you don’t need to solder things together. Instead, each row of the breadboard is electrically connected so you can plug wires into the holes to form electrical circuits. We will be using a mini solderless breadboard (pictured to the right, on the top), but there are other kinds of solderless breadboards as well (example pictured to the right, on the bottom).

Mini SPST Momentary Pushbutton Switch
This button will connect the electrical circuit and start the sensor when it is pressed. Make sure you work with the kind of mini pushbutton that has four small prongs (the two-pronged mini pushbuttons do not fit in the breadboard). (pictured to the left)

Jumper Wires
These wires are used to connect the components of the machine. The colors are only used for organization! (I repeat, the colors of the wires do not matter, but to ensure you are completing each step correctly, it may be easier to use the same color wires we use in the diagrams in step 6). (pictured to the right)

10K OHM Resistor
A resistor is a device with a designed resistance to the passage of electric current. (pictured to the left)

LED
This is a small light which can be used to test whether things are working correctly (electrically connected). (pictured to the right)

5V Micro USB Wall Charger
This will be used to power the machine. Alternatively, you could use a portable battery pack if you want a more a portable device.
Step 2

Accounts

Temboo and Twilio

You will need to make two online accounts for this project: Temboo and Twilio, which both have free trials. These accounts coordinate sending the text messages when the vibrations of the washer or dryer stop. Tempo gives you the first two weeks for free and Twilio gives you a starting balance to work with.

**Temboo**

1. Go to [temboo.com/signup](http://temboo.com/signup)
2. Enter a project name, then your name, company, email and password.
3. Click the ‘try it now’ button and skip past the introduction.
4. Once you have made an account you should be on the Temboo Account page. From there, select ‘Applications’ on the dropdown menu under your application name.
5. Record your Account, Application, and Key (see picture below). We will be using these values later when programming the Arduino Yun.

![Temboo Account](image)

**Twilio**

1. Go to [twilio.com/try-twilio](http://twilio.com/try-twilio)
2. Enter your name, email and password then hit ‘get started’.
3. It will ask you for your phone number to send you a verification code verifying that you are human. Enter the verification code and submit, then give your project a name.
4. Once you’ve made your account, you should end up on the Twilio Dashboard. Record your Account SID and Auth Token, which should be at the top of the page (see picture below). For the Auth Token, you have to click on the eye symbol to display.

5. Create your Twilio number, which is the randomly generation phone number that the texts will be sent to. Go to Programmable SMS, which is the messaging button underneath the house symbol on the left side (see below). Click on Learn & Build, then Get a Number at the top of the screen. Once Twilio has generated a number for you to use, click choose this number, and record what the number is.
Wireless Network
Connect Arduino Yun to Wireless Network*

1. Plug the small end of the micro USB cable into your Arduino Yun and the other end into your computer. Wait about 60 seconds for the Yun to boot up. When the Yun is ready to go, you will see the blue USB LED turn on (WLAN, see below).

2. When you first power up the Yun, it will automatically create a wifi hotspot called something like 'Arduino Yun-XXXXXXXXXX'. Check the available wifi networks on your computer for this network and connect to it.

3. Open a web browser and go to: http://arduino.local

   Note: If this link doesn’t work, go to 192.168.240.1 — When we were working through this step, we found this address to be more reliable. When prompted for a password, enter “arduino” and click ‘log in’ button

4. The configure wizard should pop up. Enter a unique name for your Arduino Yun in the Board Name field, followed by a password of your choice in the password field, then select a timezone from the dropdown menu*.

5. Select the wifi network of your choice, or enter it manually if it doesn’t show up on the dropdown menu.
If you are using the UPS wifi, you will have to use PS-GuestAccess network because the device needs special permission to use the main network (this network does not need a password so leave that area blank).

If you are using another network (say, at an off campus house), select the security type and enter the password in the password field.

Note: Make sure to get the password right, because it will not alert you if you get it wrong. If your Arduino reboots but you still see its ‘Arduino Yun-XXXXXXXXX’ as an available network option, there is a good chance you typed in the wrong wifi password.

6. Click ‘configure and restart’. Your Arduino should reset itself and join the network.

Note: When we did this, the screen would freeze when the progress bar was at 10% and error messages would appear. If this happens, disconnect the Arduino from the computer, wait a couple of minutes, then reconnect it to the computer. If the ‘Arduino Yun-XXXXXXXXX’ network does not appear, you are probably connected to the wifi. You can check the wifi status if you upload a sketch (run code to make sure that everything is working correctly). Once it is finished, you should be able to program the Arduino through the wifi network.
Step 4

Programming Environment

Download the Arduino Programming Environment *

Please note that if you are working on the computers in the UPS Makerspace, you may move forward to Step 5. This software is already downloaded on the UPS Makerspace computers and can be found on the computer desktop. If you are working on a personal computer, please continue as follows:

1. Go to aduino.cc/en/Main/Software and download the Arduino IDE. Make sure you download version 1.5 or greater. Also, make sure you download the correct package for your operating system.
2. Once the software downloads, install and open it on your computer.
3. Go to Tools > Board and select Arduino Yun
4. Go to Tools > Port and select your Arduino Yun’s name. It should have the same name you gave it before (see step 3.4) as well as the IP address.
5. To test that everything is working, go to File > Examples > 01.Basics > Blink, then click the ‘Upload’ button. You should be prompted for a password. Enter the password you chose earlier when configuring the wifi and click ‘Upload’.
6. After it is done uploading, you should see the small red LED on the Arduino blinking that is connected to pin 13 (L13, see below).

Note: If you get any errors, make sure again that the correct board and port is selected from the Tools menu and try again. You may have to click upload a few times to get it to go through.
Step 5

Programming the Arduino

Program your Arduino Yun

1. Download the file ‘MakerSpace.ino’ and open it in the Arduino software.

2. Enter the values you saved (see step 2) in the define statements for the Temboo Account, Application and Key followed by the Twilio Account SID, Auth Token, and Phone Number.

3. Enter the number where the SMS text messages should be sent in the RECIPIENT_NUMBER statement (see below).

```
// Enter your own values here:
#define TEMBOO_ACCOUNT "accountName"  // your Temboo account name
#define TEMBOO_APP_KEY_NAME "myFirstApp"  // your Temboo app key name
#define TEMBOO_APP_KEY ""  // your Temboo app key
#define TWILIO_ACCOUNT_SID ""  // the Account SID from your Twilio account
#define TWILIO_AUTH_TOKEN ""  // the Auth Token from your Twilio account
#define TWILIO_NUMBER ""  // your Twilio phone number, e.g., "+1 555-222-1212"
#define RECIPIENT_NUMBER ""  // the number to which the SMS should be sent, e.g., "+1 555-222-1212"
```

4. There are a few constant variables that you may need to adjust depending on your situation/preferences (see below):

```
// Adjust these to meet your needs
const int buttonPin = 2;  // pin number of the pushbutton
const int xPin = 3;  // pin number of the X output of the accelerometer
const int yPin = 4;  // pin number of the Y output of the accelerometer
const int ledPin = 13;  // pin number of the LED
const int waitTime = 2;  // wait time in minutes
const float sensitivityX = 0.005;  // sensitivity of X axis in percent change
const float sensitivityY = 0.005;  // sensitivity of Y axis in percent change
```

1. First, if you are using the ADXL-335, you will need to change the “xPin” variable to A0 and the “yPin” to A1.

2. The “waitTime” is approximately how many minutes the system will wait until it sends a SMS text message. This is to account for when the machine is either filling up with water or sitting idle during its cycle and not vibrating. Five minutes worked in our case, which is why “waitTime” is set to a default of 5, but you may
need to adjust this. Note that the timing isn’t exact and was just an approximation.

3. The “sensitivityX” and “sensitivityY” are values that tell the system how sensitive it should be to the vibration changes of the machine. Right now, it declares a 0.5% change as movement by the machine. Anything below this and the system assumes that the machine hasn’t moved since the last time it checked. You can adjust this to meet your own laundry machine’s needs.

5. Click the ‘Upload’ button*.

Note: We noticed that the wireless upload is not the most reliable. If the code fails to upload on the first try, keep clicking the ‘Upload’ button until it goes through successfully.
Optional: Step 5.5

Soldering

*Solder the ADXL-335 Accelerometer*

If you chose to use a new ADXL-335, you will first need to solder it to the pins so it can be electrically connected to the breadboard.

1. Plug in the soldering iron to warm up and set the temperature to 750F/400C. Make sure you are using lead-free solder.
2. While the iron is heating, dampen the sponge with a little bit of water.
3. Wipe the tip of the hot iron on the damp sponge to clean off any oxidation.
4. Apply a small amount of solder to the tip and wipe again to tin the tip. You should have a thin, shiny layer of molten solder on the tip of your iron.
5. Make sure that the accelerometer is clean. Wipe the accelerometer off with isopropyl alcohol if it looks dirty.
6. Immobilize the accelerometer. If there is any movement as the molten solder is solidifying, you will end up with an unreliable ‘cold joint’.
7. Heat the joint (where you are connecting the pin to the accelerometer) with the tip of the iron. Be sure to heat both the solder pad (the metal ring) and the wire. A small drop of solder on the tip will help to transfer the heat to the joint quickly.
8. Touch the end of the solder to the joint so that it contacts both the solder pad and the wire. It should melt and flow smoothly onto both the wire and the pad. If the solder does not flow, heat the joint for another second or two, then try again.
9. Keep heating the solder and allow it to flow into the joint. It should fill the hole and flow smoothly onto both the solder pad and the wire. It should make a tent-like shape around the wire.

10. Once enough solder has been added to the joint and it has flowed well onto both the pin and the solder pad, remove the iron from the joint and allow it to cool undisturbed.

11. Things can go wrong when soldering. Below is a visual guide to how your joint should look. If it instead looks like one of the other joints, go to https://learn.adafruit.com/adafruit-guide-excellent-soldering/common-problems, which has some useful advice on how to remedy these problems.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cold Joint with Insufficient Wetting (Pad)</td>
<td>Ok</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cold Joint</td>
<td>Too Much Solder</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insufficient Wetting (Wire &amp; Pad)</td>
<td>Ok</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insufficient Wetting (Pad)</td>
<td>Too Much Solder</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Assembling the System
Assemble your Device*

1. Disconnect your Arduino Yun from power.
2. Wire up the system as shown in the diagrams (see Appendix for closer look).

Note: Make sure you are following the correct diagram that corresponds to your chosen accelerometer! Also, make sure your Arduino has the "YUN" facing you!

3. Once they are wired up, your device should look like the following pictures.
Testing the System

Test your Device*

1. Secure your device on the top, side, or back of your desired laundry machine. You can choose to mount the device to a machine if you do not plan on moving it around from machine to machine. Keep in mind, if you choose to simply place your device on top of the machine, you should take precautions to ensure it does not fall off during operation.

2. Plug the power into the micro USB port using either a wall power adapter or a portable battery pack.

3. The timer for the system does not start until you click the little pushbutton (see left) once. So, load your laundry first and then start the cycle.

4. Once your machine is started, click the pushbutton once*. You should see the LED light up. If you do not see the LED light up, wait a few seconds or even a minute and try clicking it again. Sometimes the wifi takes a couple minutes to connect and your device will not allow you to start the system until it is done connecting to the wireless network.

5. After the LED is on, the system will immediately begin checking for movement and vibrations coming from whatever surface it is mounted to. If it detects movement (greater than the sensitivity settings), it will reset the timer and continue to monitor. If it does not detect any movement or vibrations, it will start the counter and wait until the “waitTime” (currently defaulted to ~5 minutes) passes. Once “waitTime” is reached, the Arduino Yun will wirelessly connect to the internet and send out a SMS text message to the phone number that was designated (see step 5.4).

6. If you receive a text message at the end of the machine cycle, CONGRATULATIONS, as your system is working!

Note: If you receive a text message before the machine is done, do not panic! This probably means that you need to adjust
either your “waitTime” or “sensitivityX/sensitivityY” constant variables (see step 5).

7. When the cycle is done, click the pushbutton and the LED should turn off indicating that the system will stop monitoring and stop sending out SMS text messages. Or, you could also simply unplug your Arduino Yun from power.
Extra: Step 8

3D Printing a Case
Create a Case for your Device

If you would like to print a case for your Arduino Yun device, we have created two options for you (see picture below) to make using the 3D printer in the Makerspace! If these cases do not satisfy what you are looking for, or you would like to browse other 3D object designs, two great websites to check out are:

- tinkercad.com
- thingiverse.com

First, you must choose which 3D printer you want to use: MakerBot or Onyx

**MakerBot Replicator+**
1. Supports STL and OBJ files
2. Maximum size: 11.6”L x 7.6”W x 6.5”H
3. Filament: PLA (multiple colors)

**Markforged Onyx One**
1. Supports STL files only
2. Maximum size: 12.5”L x 5.9”W x 6”H
3. Filament: PLA (multiple colors), Onyx chopped carbon fiber (black only)
Note: We recommend using the Markforged Onyx One because the carbon fiber material less likely to ‘snap’. If you are willing to print with PLA, which is a little more likely to break, then either printer will suffice.

MakerBot Replicator+

1. Ask a UPS Makerspace student worker to log you in to the computer next to the MakerBot Replicator+.

2. Navigate to the computer desktop and open the ‘MakerBot Print’ application.

3. Open the project folder then download and open the file ‘LaundrySensorCase.stl’.

   Note: If you want to 3D print a different case, download your chosen project file(s) and unzip if necessary. Also, make sure to drag any file of type ‘3D Object’ (.stl) to the computer desktop first. In the below example, you would want to drag both ‘Case-ArduinoYun-B’ and ‘Case-ArduinoYun-T’ to the computer desktop.

4. Drag ‘LaundrySensorCase.stl’ to the desktop first, then drag the file into the ‘MakerBot Print’ application window. (Alternatively, you can open the ‘MakerBot Print’ application window, click on File >
5. Organize your objects within the grid.

- Make sure your object has majority of its surface area facing down.
- Reorient if necessary: Select an object then press the orient button on the right side of the window. Proceed to increment the values until the object lays flat. (see pictures below)

Note: If you are using the ‘LaundrySensorCase.stl’ case file, reorienting will not be necessary!

6. Hit the red ‘Print’ button on the lower right corner of the screen. The filament will automatically begin to heat up and your print should start within a few minutes!

Markforged Onyx One

1. Ask a UPS Makerspace student worker to log you in to the computer next to the Markforged Onyx One.

2. Open a web browser and navigate to the 3D Printer Website: http://www.eiger.io

3. Open the project folder then download and open the file ‘LaundrySensorCase.stl’ (see steps 8.3-8.5 above).

4. Open the Eiger website browser window, click on ‘Import STL’ and select your file(s).

   Note: If your final 3D object contains multiple separate STL files, you must open and print them one-by-one.

5. Organize your objects within the grid.

- Make sure your object has majority surface area facing down.
Reorient if necessary: Select ‘Manual Orientation’ on the right hand side of the window. Adjust the settings until you are satisfied.

6. Click Save: the information for your print (time, amount of material, dimensions, etc.) will be calculated.

7. Click Print: the 3D printer will begin preparing to print and should start within a few minutes.

Once your case starts the printing process, you may leave it since it will most likely take a few hours. The Makerspace workers will unload your new case from the printer when it is finished. You will be able to find your finished case at the ‘3D Print Pick-Up’ shelf (see below).

Your new case will look something like this:
Appendix
ADXL 335